Unable to select merge fields when merging datasets

I’m trying to merge two Athena datasets, but Quicksight continues to show me a “Something went wrong” error in the “Join clauses” section (see screenshot below). No matter which which Join type I select, I get the same result, and I have logged in and out several times. I have merged datasets in the past and the other admin in our account can still merge datasets, so I believe the error is only showing for me. It’s been showing for several weeks. How should I go about fixing this?

Hi @Josh_H

Could you try opening both dataset “opportunity_cohort_ds” & “gposts_ds” and try save & publish it , ensure there is no error in the dataset . (without making any join/merge)

And suspecting table access is missing in Athena and QuickSight is not able to retrive the column list .

Thanks
Vinod

1 Like

@apjvinod I save & published both datasets and both of those datasets work on their own, but I still see the same error when I try to join them.

Any other ideas?

@Josh_H

It sounds like you’re running into a frustrating issue in Amazon QuickSight where you’re unable to join datasets together. A few things you could try to resolve this:

  • Make sure both datasets you’re trying to join have the appropriate keys defined that can be used to join them.

  • Try joining the datasets in a new QuickSight analysis to rule out any corruption in your existing one. Create a fresh analysis and attempt the join there.

  • Clear your browser cache and cookies and reload QuickSight. Sometimes stale temporary data causes weird errors.

  • Try in a different browser or incognito window. Narrow down if it’s a browser-specific problem.

  • Double check your QuickSight permissions and make sure you still have access to edit/update the datasets.

  • As a last resort, contact AWS Support. Explain the error you’re seeing and they may be able to troubleshoot further or log an internal bug.

  • Ensure the datasets are in a format the QuickSight can recognize

Without seeing the exact error it’s hard to pinpoint, but trying the above steps should hopefully resolve the inability to join the Athena datasets in QuickSight.

Let me know if the problem persists!
GL

  • Yes, both datasets have the appropriate keys, it just won’t load the list of keys to select.
  • I duplicated the dataset already for this reason.
  • I tried this.
  • Tried using a private Chrome browser window and Safari, and both had the same result.
  • Permissions are still good on these two datasets.

I’ll try contacting support and see why my user isn’t able to join these two datasets (the other user in my company’s account still can).

Thanks!

Hello @Josh_H, were you able to figure out a solution to this issue after discussing it with AWS Support? I would be interested to see what was causing the error and it could help someone else in the community who experiences the same issue. Also, let us know if you were still unable to resolve this and maybe we can find a solution.

Hi @DylanM, I wasn’t able to submit a support ticket without upgrading our support plan, so our current workaround is just to have someone else in our company join datasets when needed. Not ideal, but it works for now.

Thanks for following up and let me know if you do think of anything else we should try!

Hello @Josh_H, I just had a thought on this. I know you have ownership permissions on the datasets, but do you have access to the datasource they are connected to? Have you created a dataset in QuickSight that is connected to it? Maybe there is an issue where you don’t have ownership of the data source and that is causing this issue.

If that doesn’t resolve the issue, I will go ahead and tag this topic for our support team to view and they might be able to assist. Hopefully we can find an alternative solution, but at least you have a work-around for now.

Hey @DylanM , yes I can access both datasources in Athena, but still can’t merge the datasets myself (same error). Also, I can edit the dataset merge after it has already been merged by a teammate, I just can’t create the initial merge myself.

Hello @Josh_H, that is really interesting. I am sorry that it remains and issue, but I will tag this topic appropriately and archive it for the support team. Thank you for your feedback and the detailed responses!