Analysis not deleting


I’m trying to delete an analysis. QuickSight says it’s been deleted, however it still appears in the list and I can’t delete DataSets which are associated with it.

Is there some trick to this?

Thank you.

HI @damien no trick on this simple you can delete your analysis by selecting three dotted lines menu on the respective analysis and click on Delete. Some time what happens if you don’t have the permission you not able to delete the analysis or some time internet issues if you have internet issues then please refresh the page and check again.

For deleting the datasets go the dataset menu and select any dataset and click on three dotted line and click delete. Same rule is also applicable for the datasets.

PFB the screenshots for understanding.


1 Like


Thanks for your reply.

I did all of those things, and I had an internet connection. I refreshed the page, closed the browser etc etc. It failed to delete over a dozen times, then it deleted. Perhaps there was some eventually consistent background task which was behind?

A day or two later, this issue is recurring again. My permissions haven’t changed. My internet connection is active. What’s more, I’m getting the dialogs saying ‘deletion successful’.

It seems like a bug to me.

Kind regards.


1 Like

hi @damien,

when you try to delete dataset, you can check if the dataset has been used or not on dataset edit page - Usage pane on Summary tab.


if you still fail to delete the dataset, I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case. hope this helps.

kind reagrds,

1 Like

Hi @Wakana,

Thanks very much for your response. I’ve tried all that to no avail. I’m a Quicksight admin as well, so I would be suprirsed if it were permissions based. I could be wrong of course, but think that it’s a QuickSight.

I’ll see if I can raise a support ticket.

Thank you :slight_smile:


1 Like

Keep us posted @damien. It sounds like you know the steps to open a support case but let us know if we can help in any other way.

I ended up deleting these via the CLI. As far as I know, I’m using the same credentials here as I am in the QuickSight dashboard, so I don’t believe that’s the issue.

I have no idea why they won’t delete via the UI.

CLI command I used was

aws quicksight list-analyses --aws-account-id 123454567 --region ap-southeast-2 --profile dev12 | jq ‘.AnalysisSummaryList | map(select(.Status != “DELETED”))’ | jq ‘..AnalysisId’ -r | tr -d ‘\r’ | xargs -I parm1 aws quicksight delete-analysis --aws-account-id 123456 --region ap-southeast-2 --profile dev12 --analysis-id parm1

Thank you all for your help.