Controls do not appear in the App version

Hi there!

I have been facing an issue with the controls of my dashboards in the app version.
In the past I used to be able to use them to filter based on parameters, but now they don’t appear anymore.

It just happens in some dashboards only.
How is it possible? Can you help me to fix this?
This is so important when I am on the go in fairs and visiting suppliers.


1 Like

Hi Rodolpho_Cavalheiro,

Can you please share screenshots of the issue you are seeing? Are you able to add new controls to your analysis?

had the same issue and one of the controls was the problem. I deleted it and created it again. After this everything worked again.


Hi Peter,

Of course! I will send 2 examples of dashboards with controls both in the computer and mobile app versions.
The first dashboard has several filter controls that appear only in the computer version.
In the second one the controls are enabled in both versions.

I cannot understand why the first one does not work properly.

As I cannot attach files yet, you can find the images in the following Google Drive folder:
[QuickSight Examples - Google Drive](https://Image Folder)

Hi Thomas!

Thanks for the tip.
So you just recreated the controls, right?


Have the same problem here?

Naveed Ali

1 Like

Hi Rodolpho_Cavalheiro,

Thanks for sharing those screenshots!

Can you make sure you have “Enable ad hoc filtering” checked when you publish your dashboard?

If the filter icon still doesn’t appear after republishing your dashboard with that box checked, can you test recreating your controls as thomask suggested?

Hello there.

Unfortunately the checkbox was already enabled and it didn’t change anything. Still without the filter controls in the app.

1 Like

Hi Rodolpho_Cavalheiro,

Can you try deleting and recreating the controls you are not seeing in the mobile app? If that does not work, I will flag this post for review as this may be an issue the R&D team needs to investigate.

I’m also having the same issue with the dashboards for our company. On both the Android and iOS apps I am yet to find one of our existing dashboards where the parameter controls are available in the app.

I’ve tried republishing with all of the optional flags enabled, but with no success. I have also tried creating a simple dashboard with a single text parameter/filter/control, and still I get no controls appearing for it in the mobile app.

This was working fine a number of weeks ago.

If you are still facing this issue, I would suggest that you log a ticket so that the technical support team can debug the issue.

If you have access to the AWS console of the AWS account where you’re using QuickSight, please see these instructions 1 on how to raise a support case.
If you do not have access, you’d need to ask whoever manages your AWS account for you to raise a support ticket.



I started working through this with AWS support, who could not initially reproduce the issue. However this morning while collecting some mobile app screenshots to further illustrate the problem, the filter button resumed appearing correctly in the mobile apps for Android and iOS.

I assume an update to the supporting services was rolled out overnight or just became available in my region or QuickSight tenant. Whatever it was, things are working as expected now.

1 Like

Glad to hear that things are working as expected now @peterw! Thank you for letting us know! And welcome to the QuickSight Community! :slight_smile:

Thanks for sharing this tip with the Community, @thomask. :slight_smile: