Geospatial data is showing ambiguous for my data set

Hello. I’m trying to make a geospatial visualization on my data. I’ve set up a hierarchy of country-state-city and its not working very well on the city level. Following is a screenshot:

I’ve tried several other notations and translations for the states and cities above but I can’t seem to solve the issue of ambiguous names. Documentation didn’t help me much sadly, I’m really stumped.

Does anyone have any idea what’s going on? Is there a particular name structure of state-city that QS uses that coves brazilian locations correctly, or anything of the sort, or anything?

@Awata,

Generally you will receive ambiguous data message when map is unable to resolve the country → State → City hierarchy uniquely. Can you double check your geospatial dataset to ensure that city and states are uniquely linked.

Thanks
Deepak

Thanks for the response. I understand the ambiguous data message means there are ambiguous names in the hierarchy. My dataset contains a single hierarchy of Country → State → City and I did verify the data a few times.

Some entries work correctly, but a few important ones like Sao Paulo, which the only city named Sao Paulo in the Sao Paulo state, doesn’t seem to go through Quicksight at all.

Here’s a screenshot of the map I can see in my analysis:

image

Here’s a small sample of cities that work and doesn’t (it returns 7 ambiguous values that honestly shouldn’t, given the names are accurate). I hope that trying it out with this sample and double checking with any map search will shed some light on the subject:

Country,State,City
Brazil,Sao Paulo,Sao Paulo
Brazil,Sao Paulo,Poa
Brazil,Sao Paulo,Cotia
Brazil,Sao Paulo,Guarulhos
Brazil,Sao Paulo,Pompeia
Brazil,Sao Paulo,Sao Carlos
Brazil,Minas Gerais,Belo Horizonte
Brazil,Minas Gerais,Sabara
Brazil,Minas Gerais,Araxa
Brazil,Minas Gerais,Uberaba
Brazil,Minas Gerais,Juiz de Fora
Brazil,Maranhao,Sao Luis
Brazil,Goias,Anicuns
Brazil,Goias,Goiania
Brazil,Goias,Planaltina
Brazil,Goias,Trindade
Brazil,Goias,Morrinhos
Brazil,Goias,Rio Verde
Brazil,Rio Grande do Sul,Porto Alegre
Brazil,Rio Grande do Sul,Sao Leopoldo
Brazil,Rio Grande do Sul,Santo Angelo
Brazil,Rio Grande do Sul,Santa Maria

@Awata, thanks for sharing sample geospatial data, when I uploaded this data, I was not able to map and visualize few cities correctly as you have noted. If you have not already opened a support case, please open a support ticket so that support team can address all the geospatial data gaps relevant to your use case. I will open an internal ticket as well.

Thanks

Hey there, thanks for taking a look at this case. Sadly I forgot about this thread but I did open a support case right around the same time as I made the first post here.

Still waiting for any updates, oh well. Have a great day!

Hi @Awata we tracked down your support case and confirmed there are some issues with the underlying geocoding database on these locations. We have a planned update on the geocoding data coming end of the year (subject to change).

1 Like

Thanks, this helps me a lot actually!

Have a great day!

1 Like

Is there an update to this? I am seeing issues with UK based data too

I had the same problem and for some reason I put as “County” and worked. It’s complicated in some countries with different concepts of geolocalization, for example, in Brazil, after the States we have the Municipalities and then the Cities (urban agglomerations inside a municipality). I’d be great if the geospatial type adapts to the language used in the account.