How to get sublevel column names to use as parameters in chart titles

I have charts with acctions that send me to sub levels, but I want to get my chart title to update to include the sub level.

image

I have a working version but you might need to customize it for your solution.

First, we are going to make two parameters. DrillDownTitle , DrillDownFilter.

For the DrillDownTitle parameter I am going to set the default value to be Main.

For the DrillDownFilter parameter I am going to leave the static default value blank.

Next I am going to make a calculated field called DrillDownField.

This is the field that will change what fields get displayed on your visual.

In this case I am using the client_id as the top and the device model as the sub level.

DrillDownField = ifelse(${DrillDownTitle}=‘Main’,{client_id[users]},${DrillDownTitle}=‘Sub’,{device_model},NULL)

Next I’m going to make the donut chart with the group/color as the DrillDownField and make the title equal to the DrillDownTitle I set.

Next, I am going to set up actions to interact with the visual. I am going to set up the action type as navigation and keep the target sheet the same as the sheet the visual is on.

Then I am going to change two parameters. The first parameter is going to change the title.

image

The second change is going to be to the filter to equal the field.

image

Here is how my action looks like.

Finally, I am going to add a filter that filters the highest level (client_id[users]) to my DrillDownFilter.

When I click on the WLS group I get this. One thing to note I added the DrillDownFilter to the title to show the field it filtered down to as well.

Let me know if this helps!

2 Likes

Hi, @jhonnattan_rivera. Did Max’s solution help? We saw that you “liked” his reply, so we are marking it as, “Solution,” but let us know if this is not resolved. Thanks!