No Data to Check - Alert Error

Hey,
I tried to create an alert for a non calculated field (KPI) in a pivot table which is group by hour (date type column).
I set the alert this way:

When I refreshed the data I got this email:

What could be the problem?

Eldad Levi

Hello @Eldad_Levi !

In the value to track section, did you mark that as the whole column or as a specific cell? There could be a few reason why the email came back with no data, but just looking at your screenshot it might be that you selected the Hour field rather than a specific cell. It could also be that the email that you used to send the alert lost access to parts of or the whole dashboard.

I also recommend checking out Working with threshold alerts in Amazon QuickSight.

Hey, Thanks for responding.
I choose only one cell (The first one) and I set the alert to be regarding the latest hour.
In addition, I don’t have any problems of permissions to the data set - I am it’s owner.

I read the documentation you sent, and I haven’t found any thing that can help me.
Do you have any more ideas why doesn’t it works?

Eldad Levi

Hello @Eldad_Levi ,

When you create your threshold alert, is there a specific reason that you put it on the date hour column and not the KPI column?

Hey, Thanks for responding.
There is no option to create it differently. I clicked on the cell that I wanted to alert on (The KPI cell) and clicked on ‘Create Alert’ option.
Then the alert was created automatically.

Hey @Eldad_Levi ,

Have you continued to get emails saying the same thing or did the threshold alert automatically cancel itself? I’m curious to know if that email was sent because you have the "email me when there is no data " box checked. So if you run a refresh from your dataset and there was no updated data that’s why you received that email.

Hey, Thanks again for responding.
I did check the “email me when there is no data” box, and each time that the data set is getting refreshed - I get the alert “No Data to Check”.

Best,

Hey @Eldad_Levi !

I would try changing your threshold limit from “Is Above Zero” to something like “Greater than…” and set it to a limit that the KPI column cell should always be above. For example, “Greater than 3000” and set it for an email as frequently as possible.

Hey and thanks for responding.
After a conversation with Amazon technical team, we have found the problem.
The definition of “Hour:Latest Hour” is a reference for the current time stamp and not the latest hour in the dataset.
The latest hour in my data set is current_hour - 1, thus there is no data to present.
Thanks for helping Duncan!

2 Likes

@Eldad_Levi thank you for following up on this with the solution! I’m glad the AWS team was able to help out as well.