SKIPPED rows when refreshing datasets

Hi All,
I get skipped rows when refreshing our datasets in QuickSight, and that specifically happened after I added a new calculation. No error report either. Only input is that “index is out of bounds.” Could it be me trying to access an index of 0 with the “locate” function? Just an idea.
The calculation I used:
locate(toLower({field}),‘geo’) >0,

Thanks in advance for the help!

Hello @gian,

Welcome to the QuickSight Community, it is great having you here!

I have tried to reproduce this with a substr which is out of bounds and also with a locate but i have not been able to reporduce this error when importing.

Is it possible for you to share a sample of rows of your dataset, or a mock one, including some that fail and some that don’t so I can check the formula and reproduce the error?

Just to confirm, since the problem is on skipped rows, you calculated field is created in the dataset right?

Kind regards,

Hi @andres007 ,
Thanks so much for initially looking into this. Yes, the calculated field is created in the dataset. In the meantime, I am looking to see if I can share some data, and if so, how can I quickly spot what rows where skipped? I will update asap.


If you click the “Download error row file” you should get a file with all the rows that failed.

Kind regards,

Hi @andres007, unfortunately there is no error file/report to download. You can see from my screenshot that it says “This file didn’t generate an error report” and the “Download error rows file” is greyed out. Is there other work arounds?

Hello @gian, sorry I did not notice that in the screen shot, for this issue of the error file not being generated, I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf.

Is is possible to you to try to reduce the dataset so the number of rows on the error file are less. I do not know how big is your dataset but maybe you are hitting some of the limits for the csv files.

Please let us know if you manage to get the error rows in either of these ways.

Kind regards,

I created a subset of the data (<500 rows) and I get 2 skipped rows, but still no error file available for download. The error cause is the same: “index is out of bounds.”
As next option, I guess I need to have a support case opened on my behalf.

I think the support case will be the best option to at least understand why the file with the error is not being generated.

Please let us know if you find the error rows and can share them with us so we can try the formula and find out what the root cause is.